When i try to run pgadmin3 on my ubuntu 10.04 box i now get the following error:

$ pgadmin3
pgadmin3: relocation error: pgadmin3: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8 not defined in file libwx_baseu-2.8.so.0 with link time reference

I assume it has something to do with one of the latest updates. I run all the updates always when they are proposed, but i am not really sure this always is a good idea.

When googling the error i found a lot of links, and ultimately, also the fix:

apt-get source pgadmin3
sudo apt-get install debhelper libpq-dev libwxgtk2.8-dev libxml2-dev libxslt1-dev autotools-dev devscripts
cd pgadmin3-1.10.2
dpkg-buildpackage
sudo dpkg -i ../pgadmin3_1.10.2-1_i386.deb